Bug Request Details

Stuck on Start Screen

I've downloaded Project Felix, app starts and I get the introduction panel, as shown in image. The preview video works, the two options; "create a new project" and "start a guided tour" do not open. When either option is selected, the black triangular pointer with blue loading circle appears but program seems to get stuff at that point.

81 votes
Sign in Sign in with OpenID Connect
Signed in as (Sign out)

We’ll send you updates on this idea

Nore shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

We’ve resolved some past issues of some users not being able to use Dimension, however there is a known issue still remaining.

Video cards that do not support a specific instruction set (AVX/AVX2) will not be able to run Dimension. This is primarily video cards from early 2012 or earlier.

At this time our System Requirements checker is unable to ‘catch’ this and leads to the application crashing on the Start Screen when the New Document or Get Started buttons are clicked.

At this time we are unable to fix this issue or catch to throw an error. We are continuing investigation on this.

243 comments

Sign in Sign in with OpenID Connect
Signed in as (Sign out)
Submitting...
  • Kurt commented  ·   ·  Flag as inappropriate

    All I get is the spinning beachball id death on my imac. It will not launch although the demo window will play. My mac is up to date with latest software.

  • AdminJeanette Mathews (Product Manager, Dimension) commented  ·   ·  Flag as inappropriate

    Hi Kurt! I'm very sorry about any frustration. Felix is in it's first Preview state and still has a bit of work to go for stability. However, I'll need more information before I can help. When you say it doesn't work, what do you mean?

    Are you unable to download the application?
    Unable to launch it?
    Does it freeze or hang or crash?
    Do you see any error messages?

    If you can provide me some more details about what's going on and also post your system information, that would be a great place to start!

    System Info
    - Project Felix Version
    - OS/Version
    - Processor
    - Memory/RAM
    - Graphics Card/VRAM

  • Kurt commented  ·   ·  Flag as inappropriate

    Project Felix just does not work!! I so want to teach this to my packaging students. Is there any progress on this at all???

  • Anonymous commented  ·   ·  Flag as inappropriate

    Also same problem.

    Running OSX El Capitan
    IMac Mid 2010
    3.2 GHz Intel Core i3
    16 GB 1333 MHz DDR3
    ATI Radeon HD 5670 512 MB

  • Norm commented  ·   ·  Flag as inappropriate

    Just a +1 with the same problem.
    I really hope you guys work it out, been waiting for something like this to get started on the Adobe family for a long time!

  • Peter commented  ·   ·  Flag as inappropriate

    I to am experiencing the stuck at start up. The thing about adobe is that they don't want to or cares about testing on different machines and set ups before releasing their previews or betas.

    its a real shame.

    Running OSX El Capitan
    MacPro Early 2008
    2.8 GHz Quad-Core Intel Xeon
    32 GB 667 MHz DDR2
    NVIDIA GeForce GTX 680 2048 MB
    SSD Drives

  • Manny commented  ·   ·  Flag as inappropriate

    It seems that this is a big problem. I can't create a new project on my Mac
    Mac Pro (Mid 2010)
    3.33 GHz 6-Core Intel Xeon
    32 GB 1333 MHz DDR3
    Macintosh SSD
    NVIDIA GeForce GTX 680 2048 MB

    I just get a spinning wheel. To date no mention of this problem from Adobe. Come on Adobe lets get this issue corrected.

  • Kurt commented  ·   ·  Flag as inappropriate

    I posted a while back but have just encountered a similar issue in another program so thought I'd test the solution with Felix. Turns out when I have my monitors plugged in via a USB 3.0 dock many apps don't recognise the discrete graphics card. When a plugged a single monitor into the hdmi slot on the laptop i was able to start a new project without issue...
    Not sure if this is the same issue other people are seeing but if you can try disabling the integrated graphics card in BIOS to see if you can force it to use the discrete card.

    Windows 10 Pro
    Dell XPS15
    Core i7-6700HQ 2.6GHz
    16GB DDR4 2133 MHz
    NVIDIA GeForce GTX 960M 2GB

  • Manny commented  ·   ·  Flag as inappropriate

    I have attempted to create a new project but get the spinning ball only. I have NVIDIA GeForce GTX 680 2048 MB, 3.33 GHz 6-Core Intel Xeon, 32 GB 1333 MHz DDR3 Mac OS Sierra 10.12.3. Any ideas why this is happening? I have read numerous posts online with the exact problem.

  • MarkP commented  ·   ·  Flag as inappropriate

    Dell Precision 3420
    Windows 10 Pro
    V 1511
    OS Build 10586.753
    Intel Core i7-6700 CPU @ 3.40GHz
    16.0 GB Ram
    64 bit operating system
    Intel HD Graphics 530 graphics card

    Ap opens fine and I can view video and tutorial but when I load a model it hangs LOADING

  • Marc L commented  ·   ·  Flag as inappropriate

    Btw, yesterday I tried a workaround (which didn't work): I saved an empty project from my computer where Felix works, and tried to open it on the computer where I can't get past the start screen. All I am getting is an empty canvas, which is at least one step further, but still no solution.

  • Christiane Michelsen commented  ·   ·  Flag as inappropriate

    Same here :-( :
    Mac Pro (Early 2009), OS 10.11.6, 2 x 2,26 GHz Quad-Core Intel Xeon, 14 GB 1066 MHz DDR3 ECC, NVIDIA GeForce GT 120 512 MB

  • Tiberiu commented  ·   ·  Flag as inappropriate

    I have the same issue. I don't think it is a hardware problem, as I have a 12core MacPro, 32Gb Ram and a Nvidia GTX 980Ti 6GB.

  • Marc Chapin commented  ·   ·  Flag as inappropriate

    My Mac Pro 5,2 mid 2010 on MacOS Sierra has the same issue. I have 16GB RAM, 2x2.66 GHz 6-core intel xeon with a recently installed Nvidia Quadro K5000 4GB VRAM.

  • Haluk Gurer commented  ·   ·  Flag as inappropriate

    Same here, cannot past create new project stage. OS 10.12.2 Sierra / Mac Pro (Early 2009 but upgraded)

    2 x 3.46 Ghz 6 core Intel Xeon / 48 Gb 1333 Mhz DDR3 Ram / NVIDIA GeForce GTX 970 4096 Mb Video card

  • Per commented  ·   ·  Flag as inappropriate

    Exactly the same problem on my 27" iMac mid 2010 and ATI Radeon HD 5750 1024 MB

  • Marc L commented  ·   ·  Flag as inappropriate

    I have the same problem with my 27" iMac on MacOS. It works fine on the same machine on Windows 10 using Bootcamp. It also works fine on my 2011 MBP on MacOS, but rendering takes much longer

  • Pierre commented  ·   ·  Flag as inappropriate

    I am really looking forward to experience Adobe Felix but unfortunately untill now I am only experiencing the same problems as indicated below. I can't get past the opening screen. I run MacOs Sierra on a mid 2010 27" iMac with 16 Gb RAM.

Feedback and Knowledge Base