Bug Request Details

Dimension CC does not work on Mac Pro 5.1

macOS Mojave 10.14.3
Mac Pro 5.1 (mid 2012)
SAPPHIRE Radeon PULSE RX 580 8GB GDDR5

Only the start screen appears, on it the message "Loading application ..." and nothing more. I uninstalled and reinstalled the app, but it did not help. What is going on?

3 votes
Sign in Sign in with OpenID Connect
Signed in as (Sign out)

We’ll send you updates on this idea

Tomasz shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

The issue with older macs not launching Dimension correctly came up when we introduced our new rendering engine which has specific instruction sets that aren’t supported on older macs. We weren’t able to get enough information to fix it before so the newest build has more information in our logging system. If you can get the latest version from Prerelease and send your DimensionGPUProfiler.log file to me at tickets@adobedimension.com that’s the most helpful!

https://www.adobeprerelease.com/

If you’re not already a member, you can join the Adobe Prerelease program on that website then request access to Dimension.

2 comments

Sign in Sign in with OpenID Connect
Signed in as (Sign out)
Submitting...
  • Rafael Martinez commented  ·   ·  Flag as inappropriate

    Same here, I tried it today again hooping the issue where fixed..... but not

    Mac Pro (Early 2009)
    2 x 2,26 GHz Quad-Core Intel Xeon
    36 GB 1066 MHz DDR3
    NVIDIA GeForce GTX 1060 6GB 6143 MB

  • Michael Richards commented  ·   ·  Flag as inappropriate

    LOL! After all this time, I tried to run Adobe Dimension again, too. It still won’t work on my MacPro. I gave up trying a long time ago, but thought I’d give it another shot. What gives, Adobe?

Feedback and Knowledge Base